MorphOS.pl – Polska strona użytkowników MorphOS-a
MorphOS.pl – Polska strona użytkowników MorphOS-a

Yomgui znów w akcji6 stycznia 2014

Guillaume „Yomgui” Rodriguez po zawirowaniach związanych z przeprowadzką do Kanady, wraca do programowania na MorphOS-a. Swoje projekty umieszczać będzie od tej pory w serwisie BitBucket. Większość z nich związana jest z językiem programowania Python. I tak na początek mamy świeżą wersję samego Pythona, 2.7.6-16. Ale to nie wszystko. Jako jeden z programów w Pythonie portowanych przez Yomgui, dostaliśmy świeżą (prawie najnowszą…) wersję 2.8.1-1 Mercuriala, popularnego pakietu do zarządzania wersjami plików. Z notek na stronie wynika, że Yomgui stara się o włączenie MorphOS-a do listy systemów oficjalnie obsługiwanych przez Pythona.

Zamieszczone przez: admin, 15 komentarzy

Komentarze:

  • AvatarMDW

    Podobno ta wersja Pythona jest niezbędna do stworzenia wersji Blendera 2.63+ dla MorphOSa. To daje nadzieję, że taką zobaczymy. Ja bym się akurat z tego bardzo ucieszył, bo nie musiałbym swoich śmiesznych skryptów "IFować" żeby działały na 2.62.

  • AvatarEnder
    Z notek na stronie wynika, że Yomgui stara się o włączenie MorphOS-a do listy systemów oficjalnie obsługiwanych przez Pythona.

    No to ekstra wiadomość, rozumiem, że wtedy wersja na nasz system będzie szybciej? A jak ta wersja ma się do 3.x? Jest szansa na nowe PyGame, a może i PyGlet?

  • AvatarMDW
    No to ekstra wiadomość, rozumiem, że wtedy wersja na nasz system będzie szybciej? A jak ta wersja ma się do 3.x? Jest szansa na nowe PyGame, a może i PyGlet?

    Tego to nie wiem. Ale czy jakiś Python 3.x nie był już zrobiony na MorphOSa? Tyle tych wersji było, że już się gubię. Nie za bardzo siedzę w świecie Pythona ale mam wrażenie, że 3.x i 2.x istnieją równocześnie. Są zwolennicy 2.x. Dlatego ta wersja ciągle jest rozwijana i nie jest traktowana jako coś starszego od 3.x tylko po prostu odgałęzienie języka.
    Jeżeli mówię głupoty to proszę mnie poprawić, bo sam chętnie się dowiem.

  • AvatarEnder
    No to ekstra wiadomość, rozumiem, że wtedy wersja na nasz system będzie szybciej? A jak ta wersja ma się do 3.x? Jest szansa na nowe PyGame, a może i PyGlet?

    Tego to nie wiem. Ale czy jakiś Python 3.x nie był już zrobiony na MorphOSa? Tyle tych wersji było, że już się gubię. Nie za bardzo siedzę w świecie Pythona ale mam wrażenie, że 3.x i 2.x istnieją równocześnie. Są zwolennicy 2.x. Dlatego ta wersja ciągle jest rozwijana i nie jest traktowana jako coś starszego od 3.x tylko po prostu odgałęzienie języka.
    Jeżeli mówię głupoty to proszę mnie poprawić, bo sam chętnie się dowiem.

    Tak istnieją, ale 3.x też się rozwija i wydaje mi się, że ta, którą posiadamy nie jest tą ostatnią.

  • Avatarpero

    Sorry za głupie pytanie, ale zainstalował się mi python ale bez asygnat. Jak mają wyglądać dokładnie wpisy do user-startup?
    Mam wersję 2.5 i 2.7

  • Avatarkrashan
    Jak mają wyglądać dokładnie wpisy do user-startup? Mam wersję 2.5 i 2.7

    Python nie wymaga żadnych wpisów do user-startup…

  • Avatarpero

    Python nie wymaga żadnych wpisów do user-startup…
    To coś u mnie zidiociało…
    System melduje brak bibliotek w libsach, a te tam są…

  • AvatarMDW

    Ja już trochę głupieję z tym Pythonem. Mam tego już tyle na dysku, że się zgubiłem. 🙂 Które wersje powinienem mieć? Dodam, że nie jestem fanem Pythona. Po prostu chcę go mieć, bo jest potrzebny do Blednera i chcę żeby się uruchamiało wszystko co tam Yomgui zrobi (np. ten jego program graficzny). Wywalę wszystkie i zainstaluję najnowszą 3.x i najnowszą 2.x. Chyba nic więcej mi nie trzeba.

    Ciekawe, że przy próbie rozpakowania archiwum z Pythonem 2.7 (python-2.7.6-16.lha z morphos-files.net) jeden plik się nie rozpakowuje:

    *** Error on file ‘LICENSE’ : I/O Error
    WARNING: Skipping corrupt/extraneous data
    2135 files extracted, 1 file failed.

    Operation not entirely successful.

    MOSSYS:C/LHa failed returncode 10

    Jest to akurat plik LICENSE więc nieistotna strata. 🙂

  • Avatardeez
    Ciekawe, że przy próbie rozpakowania archiwum z Pythonem 2.7 (python-2.7.6-16.lha z morphos-files.net) jeden plik się nie rozpakowuje:
    *** Error on file ‘LICENSE’ : I/O Error

    Hehe, teraz patrze, że bardziej przewrażliwiony jesteś podczas rozpakowywania czegokolwiek. Zip zmienił życie raz na zawsze;-)

  • Avatarede
    Ja już trochę głupieję z tym Pythonem. Mam tego już tyle na dysku, że się zgubiłem. 🙂 Które wersje powinienem mieć? Dodam, że nie jestem fanem Pythona. Po prostu chcę go mieć, bo jest potrzebny do Blednera i chcę żeby się uruchamiało wszystko co tam Yomgui zrobi (np. ten jego program graficzny).

    Zdaje się 3.x to chyba ten co obecnie Grunch instaluje, czyli ten co podałem w linku.

  • Avatarkrashan
    Ja już trochę głupieję z tym Pythonem. Mam tego już tyle na dysku, że się zgubiłem. 🙂 Które wersje powinienem mieć?

    Na MorphOS Files są obecnie 4 wersje . Najstarsza, 2.4.4 jest potrzebna tylko i wyłącznie do używania starego portu Blendera 2.46. Po co używać tak starego portu? Może ktoś lubi, albo chce się bawić Blenderem na Efice. Nowy Blender używa Pythona 3. Wersja 2.5.4 była potrzebna do któregoś wcześniejszego programu Yomguia, nie pamiętam już którego. 2.7.6 z kolei jest do Mercuriala. Możliwe, że 2.5.4 można wywalić i zastąpić 2.7.6, nie chciało mi się sprawdzać. I za ten właśnie bałagan nie lubię Pythona .

    Ciekawe, że przy próbie rozpakowania archiwum z Pythonem 2.7 (python-2.7.6-16.lha z morphos-files.net) jeden plik się nie rozpakowuje:

    Już usunąłem ten problem.

  • AvatarAS
    Tu jest jeszcze ciut nowszy Python 3.2.2-176,
    polecam do ostatniego Blendera3D.

    Dobrze zainstalować tę wersję 3.2.2-176 do Blendera 2.62, ja miałem wersję 3.2.2-175 i Bleneder wywalał mi jakieś błędy. Przy tej nowszej błędu zniknęły.

  • AvatarMDW
    Na MorphOS Files są obecnie 4 wersje

    Dzięki za wyjaśnienie. Trochę mi się uporzadkowało. Wywaliłem te starsze i zostałem przy 2.7 i 3.2. Żeby było zabawnie to Yomgui szykuje Pythona 3.3, bo on jest wymagany przez nowsze wersje Blendera. 🙂 Mam jednak nadzieje, że ten zastąpi 3.2, którego będzie można wtedy wywalić.

    I za ten właśnie bałagan nie lubię Pythona .

    Tak, to trochę dziwne, że jeden program wymaga Pythona 2, inny Pythona 3. W dodatku wygląda jakby jeden wymagał 2.5, a drugi 2.7. Tego właśnie nigdy nie wiemy, a zgłębiać tematu faktycznie nie bardzo się chce skoro nie jest się fanem Pythona. Ten lekki bałagan przypomina mi nieco .NET w którym też trzeba było mieć kilka wersji żeby wszystko grało. A to dziwne, bo to dosyć nowy język i gdy był tworzony ludzkość miała już sporą wiedzę i doświadczenie żeby zaprojektować coś co nie spowoduje aż takiej fragmentacji. Trochę to dezorientuje i jest problematyczne.

  • Dodaj komentarz

    Witryna wykorzystuje Akismet, aby ograniczyć spam. Dowiedz się więcej jak przetwarzane są dane komentarzy.